SketchUp Plug-in | Getting Started

This section provides general information about the new 0.9.0 release of the OpenStudio SketchUp Plug-in. Clicking the image below will open an interactive PDF file. The Reference Guide and Tutorials sections will be updated soon.

Release Notes page (New Features and Known Issues)
Installation Instructions page

Click the image below to open an interactive PDF outlining a basic workflow in which the OpenStudio SketchUp Plug-in and the OpenStudio Application tools are needed.

        070 pdf screenshot

Screenshot of OpenStudio Application With Labels
(Credit: David Goldwasser/NREL)

Comments

SketchUp Plug-in error after upgrade

Dear Forum, After upgrading to Openstudio 1.3 and EPlus 8.1, I get this error after loading SketchUP 8:
Error Loading File C:/Program Files (x86)/Google/Google SketchUp 8/Plugins/OpenStudio/Startup.rb
Unable to initialize OpenSSL: Verify that ruby can access the OpenSSL librariesError Loading File OpenStudio.rb
Unable to initialize OpenSSL: Verify that ruby can access the OpenSSL libraries
I can run ruby scripts from the command line after having edited the path variable:
C:\Program Files (x86)\OpenStudio 1.3.0\Ruby> ruby -v
ruby 1.8.6 (2009-06-08 patchlevel 369) [i386-mswin32]
When I open startup.rb from the command line, I get this message:
C:\Program Files (x86)\Google\Google SketchUp 8\Plugins\OpenStudio>ruby startup.rb
startup.rb:25:in `require': no such file to load -- OpenStudio/OpenStudio-config (LoadError)
        from startup.rb:25
Line 25 in startup.rb declares:
require 'OpenStudio/OpenStudio-config'
Openstudio-config.rb can be found in C:\Program Files (x86)\OpenStudio 1.3.0\Ruby\Plugins\OpenStudio\. It declares
require 'C:\Program Files (x86)\OpenStudio 1.3.0\Ruby\openstudio'
I can run openstudio.rb:
C:\Program Files (x86)\OpenStudio 1.3.0\Ruby>ruby openstudio.rb
OpenSSL loaded
Why is the plug-in failing? Any help or hint is appreciated! Regards, Peter
Windows7Pro64bit; Sketchup8; Openstudio1.3; EPlus8.1

Is SketchUp 8.0 installed on

Is SketchUp 8.0 installed on your computer in the regular location: C:\Program Files (x86)\Google\Google SketchUp 8?  If so, maybe you installed SketchUp after OpenStudio?  I would try re-installing OpenStudio and see if that works.  As a last resort you can copy the files at: C:\Program Files (x86)\OpenStudio 1.3.0\Ruby\Plugins to your SketchUp plugins directory: C:\Program Files (x86)\Google\Google SketchUp 8\Plugins.

Finally OpenStudio 1.3.0 works with EnergyPlus 8.0 and not with EnergyPlus 8.1.  You can either install EnergyPlus 8.0 or intall the newest iteration build of OpenStudio which has been updated to EnergyPlus 8.1.


Dan

SketchUp Plug-in error after upgrade

Hi Dan, Thank you for your help! As you can see in the third code section above, SketchUP 8 is installed as you mentioned. I also did not install SketchUP after Openstudio. I once again re-installed the latest versions of OpenStudio and EnegyPlus but no avail. I also tried your "last resort" but no success... Yet, I am pretty sure that everything worked fine before upgrading. Ruby works at the command line, all the requires seem to be OK (please look again at my initial message). For now I am out of options. Any more suggestions? Regards, Peter
Windows7Pro64bit; Sketchup8; Openstudio1.3; EPlus8.1

Hi Peter, do you happen to

Hi Peter, do you happen to have any other plugins installed?  I wonder if some other plugin is loading a different set of OpenSSL libraries that is conflicting with ours.  You might try disabling any other plugins to see if that helps.

Dan

SketchUp Plug-in error after upgrade

Hi Dan, No other plugins installed. In preferences > extensions all standard settings disabled except OpenStudio. Error mesaage remains. Regards, Peter
Windows7Pro64bit; Sketchup8; Openstudio1.3; EPlus8.1

This is very odd, at this

This is very odd, at this point I would suggest the following:

  1. Disable the OpenStudio plugin in SketchUp's extension dialog, close SketchUp
  2. Starting SketchUp using dependency walker, http://www.dependencywalker.com/
  3. Enable the OpenStudio plugin in SketchUp's extension dialog
  4. Look for error messages related to OpenSSL in dependency walker

HTH,
Dan

can't find open studio toolbar in sketch up pro 14

Hi there, i've just installed Scetch up pro14 and open studio 1.3.0 but during the install process gives a message like it can't find the sketch up

The main OpenStudio

The main OpenStudio distribution is not yet compatible with SketchUp 2014, see this post:

https://openstudio.nrel.gov/forums/openstudio-plug-sketchup/general-disc...

Sketchup Error loading file

Hello, i have installed energy plus 8.1 (tried it with 8.0 as well, since two different pages post two different suggestions), and latest sketchup plugin openstudio(currently not open studio itself, but i had that as well at one point). I am running windows 7, and i tried all the different combinations of instalations of different versions with no result. Closest I get to running it is when i install it into native sketchup folder hidden somewhere in my system. This is however error I get. The files are all in appropriate locations. Please help me. miro Error Loading File C:/Users/Acer/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/OpenStudio/lib/Startup.rb Error: # C:/Users/Acer/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/OpenStudio/lib/Startup.rb:27:in `<' C:/Users/Acer/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/OpenStudio/lib/Startup.rb:27:in `' C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/extensions.rb:197:in `require' C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/extensions.rb:197:in `load' C:/Users/Acer/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/OpenStudio.rb:155:in `register_extension' C:/Users/Acer/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/OpenStudio.rb:155:in `'

I believe you are having

I believe you are having trouble with the legacy OpenStudio plug-in.  This should be compatible with SketchUp 2014 and EnergyPlus 8.1, if there is a problem with that please post it to the legacy OpenStudio plug-in mailing list: https://lists.sourceforge.net/lists/listinfo/openstudio-support.

The new OpenStudio platform (which is still using EnergyPlus 8.0 but will be converting to EnergyPlus 8.1 at version 1.3.2) is not yet compatible with SketchUp 2014, please see this post: https://openstudio.nrel.gov/forums/openstudio-plug-sketchup/general-disc....

Can not run EnergyPlus in OpenStudio Plugin

I have installed Google SketchUp v.8 and OpenStuido v.1.0.11 and EnergyPlus v.80008.I can not use the OpenStudio Plugin to simulate my model in SketchUp. When I click the "Run" button,just nothing happened.Are there some softwares I lost? or some other reasons? Could anyone please help me to figure it out?

Hi Jason, it seems like you

Hi Jason, it seems like you have downloaded the legacy OpenStudio plug-in instead of the new OpenStudio application suite.  The legacy plug-in works directly on IDF files and not on the OSM OpenStudio model format.  Version 1.0.11 of the legacy plug-in works with version 8.1 of EnergyPlus so you will want to get that version of EnergyPlus to work with the version of the legacy plug-in you have. 

Cannot find the OpenStudio toolbars in SketchUp

I have installed OpenStudio v. 0.10.0 (build 10520) and Google SketchUp Make v. 13.0.3689. I do not have any of OpenStudio toolbars in SketchUp. Tried re-installing both programs in various orders, nothing helped. Are these two compatible? Can I even install the toolbars/plug-in for the latest version of SketchUp? Thanks.

SketchUp 2013 (Make and Pro)

SketchUp 2013 (Make and Pro) are installed at a new location relative to SketchUp 8 and earlier. Our older installers don't look for the new location, but you can get our 0.11.5 installer on the developer page. It will find SketchUp. If you need to use the older version you can manually copy the plugin files from SU 8 to SU 2013 and it will work, but if you can just download OpenStudio 0.11.5 or later.

David


--
David Goldwasser, LEED AP
National Renewable Energy Laboratory
OpenStudio IconOpenStudio Developer

idf from other software

Hi-I'm also trying to use SketchupMake with OpenStudio 1.0.0 (build 12393)- I do not have Sketchup8 installed. Does this need to happen first? I am not finding how to install the OpenStudio plug in while in SketchupMake- does someone know the path to make this happen? I have already installed EnergyPlus v7.2 to try with other third-party energy programs. A broader question: if I am importing an IDF into the OpenStudio application do I even need Sketchup? Thanks-

Open Studio Menu goes grey

I have saving multiple copies while working in the "Zone" with the Open Studio menu acivated. Problem is that I have crashes and I cannot get back to where I was working on the geometry with the Open Studio menu active.

Can you post to the forum

Can you post to the forum with more detail on what you are doing leading up to a crash, and maybe also email sample file to OpenStudio@NREL.gov.

David


--
David Goldwasser, LEED AP
National Renewable Energy Laboratory
OpenStudio IconOpenStudio Developer

Open Studio menu bar in Google Sketchup

Hi all, I have Google sketchup 8. I`ve installed the latest Open studio 0.7.0 Legacy OpenStudio Plug-in for Google SketchUp Version 1.0.8 I have two problems: A. for some reason I do not have the Open Studio menu bar (the file manager part. the 3 colored-box-like icons). B. Whenever I save a model and close sketchup, if I re-open the model - I can not edit it or change anything. help anyone? Thanks!

Install problem

Dear, I followed the Installation instruction page to download the Google Sketch up plugin. The problem is the toolbar that I get is different than the one shown in the PDF above. Can anyone help me with an explanation? Thank you,

Go to "Toolbars" under SketchUp's View menu

When you install SketchUp it may show the "Getting Started" toolbar. The one shown on the left side of the screenshot above is the "Large Tool Set" toolbar. You can turn these on and off under the View Menu/Toolbars. OpenStudio also has three toolbars, two of which are pictured above. The "OpenStudio Animation" toolbar is not pictured above and generally not needed.

As far as the positioning of the toolbars. You can move them around and re-orient them. They can be docked or floating.

David


--
David Goldwasser, LEED AP
National Renewable Energy Laboratory
OpenStudio IconOpenStudio Developer

I think he's referring to all

I think he's referring to all the toolbars located at the top such as file management etc. I have the same issue with the latest version of the plugin (1.0.7.390). I have to admit due to lack of time at the moment I haven't been researching a lot into this but it appears that all the video tutorials on here refer to v0.6.0. So I guess the toolbar layout substantially changed since then? I am a first time user of the plugin and familiar with Sketchup only very limitedly. Thanks, Tobias

It is a little confusing but

It is a little confusing but the OpenStudio legacy plug-in is at version 1.0.7 while the newer OpenStudio platform is at version 0.6.0.  The OpenStudio platform is more comprehensive than the legacy plug-in and includes more functionality.  Does that help?

Dan

Can't download openstudio 0.8.1.9396-Windows.exe

Hi, I'm having a bit of problem downloading the new openstudio (also the previous version). I managed to download up to 80% and the downloading process stop. What is the difference between openstudio & legacy openstudio? Please help. Thanks Faiz

Please send an email to

Please send an email to OpenStudio@NREL.gov with your operating system and we can send you a temporary link. The legacy OpenStudio only works with IDF files, and doesn't have spaces or space types. The beta OpenStudio on this website uses OpenStudio Model files (OSM).

David


--
David Goldwasser, LEED AP
National Renewable Energy Laboratory
OpenStudio IconOpenStudio Developer